Ruby - Qt4-qtruby i Korundum

Dla Ruby API biblioteki Qt4 dostarcza pakiet qt4-qtrury, a dla Qt3/KDE istnieje pakiet Korundum.

API biblioteki Qt4 dla języka Ruby dostarcza pakiet qt4-qtruby. Wraz z KDE rozprowadzany jest pakiet korundum udostępniający API Qt3 dla KDE 3. W KDE 4.1 w kdebindings powinien być dostępny już odpowiedni pakiet dla Qt4 i bibliotek KDE. KDE 4.1 można zainstalować również pod MS Windows i Mac OS X. W chwili pisania artykułu pakiet qt4-qtruby nie kompilował się jeszcze względem Qt w wersji 4.4.1 (wymaga niższych wersji Qt4). Przewodnik i wprowadzenie do qt4-qtruby znajdziemy na stronie Qt4 Tutorial for Ruby. Na stronie projektu Korundum/Qtruby znajdziemy najnowsze pakiety QtRuby, w tym binarne paczki dla MS Windows.

Poniżej prosty przykład wykorzystania qt4-qtruby. Dla najnowszych wersji qt4-qtruby zamiast require 'Qt4' należy stosować require 'Qt'. Zapisz poniższy kod w pliku "test.rb" i uruchom go poleceniem "ruby test.rb":

require 'Qt'

app = Qt::Application.new(ARGV)

quit = Qt::PushButton.new('Zamknij')
quit.resize(75, 30)
quit.setFont(Qt::Font.new('Times', 18, Qt::Font::Bold))

Qt::Object.connect(quit, SIGNAL('clicked()'), app, SLOT('quit()'))

quit.show()
app.exec()
W powyższym przykładzie tworzymy okno z przyciskiem (PushButton) o napisie "Zamknij", po kliknięciu w którego aplikacja zakończy swoje działanie.

blog comments powered by Disqus

Kategorie

Strony